Critical Service Outages
Incident Report for Allen ISD Information Technology
Resolved
This incident has been resolved.
Posted Dec 06, 2021 - 08:57 CST
Update
We are continuing to work on a fix for this issue.
Posted Dec 06, 2021 - 08:57 CST
Update
We are continuing to work on a fix for this issue.
Posted Oct 04, 2021 - 11:40 CDT
Update
We are continuing to work on a fix for this issue.
Posted Sep 21, 2021 - 12:22 CDT
Identified
This is to inform you that the Technology department is working to get all services back online. Print Services as well as services below are impacted. Thank you for your patience.
Posted Sep 21, 2021 - 12:17 CDT
Investigating
This is to inform you that we are currently experiencing an outage of critical systems. The following services are unavailable:

• Skyward Student
• Skyward Finance
• Desktop Phone System
• Active Directory Services

We will update this status as we resolve the issue.
Posted Sep 20, 2021 - 06:44 CDT
This incident affected: Academic Instructional Services (Eduphoria), Telecommunications Systems (Campus - Bell/PA System), and Business Operations Services (Technology HelpDesk System).