Follett Destiny Service Update

Incident Report for Allen ISD Information Technology

Resolved

This incident has been resolved.
Posted Aug 18, 2025 - 16:17 CDT

Investigating

Follett Destiny is currently reporting outages. Users may experience issues such as slow performance, connectivity problems, or the application not loading.

Impact:

Access to Follett Destiny may be interrupted

Certain features may be unavailable

Allen ISD is monitoring the situation. The outage appears to be on Follett’s end, and they are investigating the issue. We will provide updates as more information becomes available.

Thank you for your patience while this issue is being resolved.
Posted Aug 18, 2025 - 10:30 CDT
This incident affected: Academic Instructional Services (Destiny Library Systems).