HMH Service Interruption

Incident Report for Allen ISD Information Technology

Resolved

This incident has been resolved.
Posted Sep 19, 2025 - 16:06 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 19, 2025 - 13:01 CDT

Investigating

Dear Allen ISD Staff,

Status Update: HMH Service Interruption

HMH have confirmed some users may experience errors or slowness when loading content, including the Home, Class Overview and Discover tabs.

They are working to address this issue as quickly as possible and in communication with school districts accordingly.

We will provide an update when the issue has been resolved in HMH's infrastructure.

Thank you for your patience.

Respectfully,
Allen ISD Information Technology Department
Posted Sep 19, 2025 - 09:45 CDT
This incident affected: Academic Instructional Services (Other Teaching & Learning Platforms).