Chromebook Login Issues – Google Service Outage

Incident Report for Allen ISD Information Technology

Resolved

The earlier issue causing a 502 Bad Gateway error and preventing students from logging in to Chromebooks has now been resolved by Google. All sign-in functionality and Google services are working normally again.

Thank you for your patience while this issue was addressed.
Posted Aug 21, 2025 - 11:26 CDT

Investigating

We are currently experiencing a 502 Bad Gateway error when students attempt to log in to their Chromebooks. This indicates a server-side issue on Google’s end and is impacting access to multiple Google services, including sign-in functionality.

Impact:

Students are unable to log in to their Chromebooks

Access to certain Google services may be limited

This issue is on Google’s side, and their team is actively working to resolve it. We will provide updates as soon as service is restored.

We apologize for the inconvenience and appreciate your patience.
Posted Aug 21, 2025 - 09:53 CDT
This incident affected: Academic Instructional Services (Other Teaching & Learning Platforms).