Winocular and Powerschool Perform Access Outage
Incident Report for Allen ISD Information Technology
Resolved
Access to Powerschool Perform and Winocular has been restored.
Thank you for your patience as we worked to resolve this issue.
Posted Jan 12, 2023 - 11:35 CST
Identified
Powerschool Perform and Winocular are currently inaccessible. The Information Technology department has identified the issue and is working expeditiously to restore access as soon as possible.
Posted Jan 11, 2023 - 22:04 CST
This incident affected: Business Operations Services (WinOcular Systems).