Users unable to login to Clever due to Amazon AWS Issue

Incident Report for Allen ISD Information Technology

Resolved

Amazon AWS has resolved this issue, and everything is back to normal.
Posted Feb 11, 2026 - 10:41 CST

Identified

Amazon AWS, a service that works with Clever, is experiencing an issue that is preventing users from being able to log in to Clever. Amplify/MClass and other applications may also be affected. We are monitoring the situation and will provide updates as more information become available.
Posted Feb 10, 2026 - 16:46 CST
This incident affected: Academic Instructional Services (Clever).