Duo 2FA Platform - Duo Push Failure Reported
Incident Report for Allen ISD Information Technology
Resolved
This incident has been resolved. Duo 2FA is reporting all services are fully functional.
Posted May 13, 2024 - 19:27 CDT
Monitoring
Duo 2FA Platform is currently investigating an issue causing failures with Duo Push. AISD staff reported problems appear to have been resolved. Duo 2FA will continue to monitor Duo Push. https://status.duo.com/
Posted May 13, 2024 - 15:17 CDT
This incident affected: Data Applications (Allen ISD Data Dashboard).