Outlook Sign-In Issue

Incident Report for Allen ISD Information Technology

Resolved

The issue affecting Outlook sign-in has been resolved. Users should now be able to sign in without any issues.

If you’re still experiencing difficulties, please call the Help Desk at 469.675.2000 or submit a help ticket.

Thank you for your patience and understanding while we worked to fix this!
Posted Jun 04, 2025 - 09:25 CDT

Investigating

We’re currently experiencing issues with signing in to Outlook for multiple users. Our team is aware of the problem and actively working to get things back up and running as soon as possible.

We’ll continue to provide updates and let everyone know as soon as this issue is resolved.

Thank you for your patience and understanding!
Posted Jun 04, 2025 - 08:08 CDT
This incident affected: Collaboration and Sharing (Office 365 - Exchange Email Services).