Imagine EdgeEX/Edgenuity - Educators may experience degraded performance

Incident Report for Allen ISD Information Technology

Resolved

The degraded performance issue with EdgeEX/Edgenuity has been resolved. Users should be able to resume activities without difficulty. Thanks for your patience.
Posted Jun 09, 2025 - 14:58 CDT

Investigating

The Imagine Learning team is actively investigating an issue impacting users of Imagine EdgeEX/Edgenuity. Educators may experience degraded performance. They will provide an update soon.
Posted Jun 09, 2025 - 08:27 CDT
This incident affected: Academic Instructional Services (Other Teaching & Learning Platforms).