Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 03, 2025 - 08:00 CDT
Scheduled
Dear Allen ISD Staff,
On Friday, October 3, 2025, from 8:00 a.m. to 12:00 p.m. CT, the Information Technology Department will perform limited scheduled maintenance and infrastructure upgrades. During this time, the Data Dashboard will be temporarily unavailable.
The Professional Learning site will remain accessible for registration and completion of professional learning activities. However, the “My Transcript” area—including course and building reports—will not be available during the maintenance window.
We will inform all staff as soon as systems are fully operational at the end of the scheduled upgrades.
Thank you for your understanding as we continue to upgrade and modernize Allen ISD systems.
Respectfully,
Allen ISD Information Technology Department
Posted Sep 29, 2025 - 16:54 CDT
This scheduled maintenance affected: Data Applications (Allen ISD Data Dashboard).