Canvas Issues

Incident Report for Allen ISD Information Technology

Resolved

Hello,

The issues affecting Canvas have been resolved, and all services are now functioning normally.

Please let us know if you experience any further issues.

Thank you for your patience and understanding.
Posted Mar 05, 2025 - 10:00 CST

Investigating

We are aware of ongoing issues affecting Canvas. Instructure, the provider of Canvas, is actively investigating the matter and working toward a resolution.

We will provide updates as soon as more information becomes available.

Thank you for your patience and understanding.
Posted Feb 28, 2025 - 11:26 CST
This incident affected: Academic Instructional Services (Canvas).