The issue affecting outgoing calls has been resolved. All services are now operating normally. We will continue to monitor the system to ensure stability.
Posted Mar 26, 2025 - 09:34 CDT
Monitoring
**Update: Desk Phones Back Online**
Dear Allen ISD Staff,
A fix has been applied, and all phone services, including Inbound and outbound calls, are operating normally as of 8:10 AM today. We will continue to monitor the situation to ensure stability.
Thank you for your patience.
Best regards,
Allen ISD Information Technology
Posted Mar 26, 2025 - 09:02 CDT
Investigating
Dear Allen ISD Staff,
Please be advised that desk phones are currently unable to make or receive external calls. However, internal extension dialing is still functional. Our team is actively working to resolve the issue and will provide updates as soon as possible.
Thank you for your patience and understanding.
Best regards,
Allen ISD IT
Posted Mar 26, 2025 - 07:44 CDT
This incident affected: Telecommunications Systems (Voice Over IP Phone System).