Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 20, 2025 - 18:00 CDT
Update
Allen Staff,
All Allen ISD Skyward platforms will be under maintenance from Friday, June 20 at 6:00 p.m. through Saturday, June 21 at 6:00 p.m. as the hosting provider completes system updates and maintenance.
We apologize for the disruption and appreciate your understanding as this necessary work is completed to ensure continued reliability and performance.
Thank you!
Posted Jun 16, 2025 - 12:11 CDT
Update
We will be undergoing scheduled maintenance during this time.
Posted Jun 16, 2025 - 12:10 CDT
Scheduled
Allen Staff,
All Allen ISD Skyward platforms will be under maintenance from Friday, June 20 at 6:00 p.m. through Saturday, June 21 at 6:00 p.m. as the hosting provider completes system updates and maintenance.
We apologize for the disruption and appreciate your understanding as this necessary work is completed to ensure continued reliability and performance.
Thank you!
Posted Jun 20, 2025 - 18:00 CDT
This scheduled maintenance affected: Skyward Applications (Family Access, Finance - HR Systems, Student Information Systems).