Eduphoria Outage

Incident Report for Allen ISD Information Technology

Resolved

The incident with Eduphoria has been resolved. If you are still experiencing any issues, please submit a help ticket for further assistance.
Posted Feb 13, 2025 - 08:12 CST

Monitoring

Eduphoria should now be available on the Allen ISD Portal. If you do not see the icon, please try logging out and back into the portal.
Posted Feb 12, 2025 - 11:48 CST

Investigating

We are currently experiencing an issue with Eduphoria. Our team is actively working on a solution.
We will provide updates on this page as the status changes.
Thank you for your patience and understanding.
Posted Feb 12, 2025 - 11:40 CST
This incident affected: Academic Instructional Services (Eduphoria).