Skyward Student
Incident Report for Allen ISD Information Technology
Resolved
This incident has been resolved.
Posted Nov 07, 2024 - 08:34 CST
Investigating
Hello Allen ISD Staff,

Skyward Student is currently experiencing degraded performance.

Our hosting provider is aware of the issue and is actively working on a resolution.

We appreciate your patience. We will keep you updated on progress and notify all staff as soon as the system is operating at full capacity again.

Thank you for your understanding,

Allen ISD Technology Team
Posted Nov 06, 2024 - 11:41 CST
This incident affected: Skyward Applications (Student Information Systems).