Google Authentication Updates
Incident Report for Allen ISD Information Technology
Resolved
This incident has been resolved.
Posted Aug 19, 2021 - 14:47 CDT
Identified
Authentication to Allen ISD Google Services is currently intermittent. The Technology department is working on updates to restore access as quickly as possible.
Posted Aug 18, 2021 - 17:43 CDT
This incident affected: Collaboration and Sharing (Google G-Suite - Classroom, Google G-Suite - Gmail, Google G-Suite - Drive).