LaserFiche Outage
Incident Report for Allen ISD Information Technology
Resolved
This incident has been resolved.
Posted Oct 20, 2023 - 13:49 CDT
Investigating
We are currently investigating this issue.
Posted Oct 20, 2023 - 11:37 CDT
This incident affected: Business Operations Services (Laserfiche Document Management).