Degraded Performance - Scan to Email
Incident Report for Allen ISD Information Technology
Resolved
This incident has been resolved.
Posted Feb 06, 2024 - 16:23 CST
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 06, 2024 - 11:24 CST
This incident affected: Telecommunications Systems (Scan-to-Email).