Skyward Authentication Delays/Slowness
Incident Report for Allen ISD Information Technology
Resolved
This incident has been resolved.
Posted Oct 24, 2023 - 08:12 CDT
Monitoring
A fix has been implemented and the IT Department is monitoring the results.
Posted Oct 23, 2023 - 11:22 CDT
Investigating
We are aware of the slowness associated with Skyward logins and are currently investigating the issue.
Posted Oct 23, 2023 - 11:12 CDT
This incident affected: Skyward Applications (Family Access, Finance - HR Systems, Student Information Systems).