Canva Sharing & Student Access

Incident Report for Allen ISD Information Technology

Update

Hello,

The Canva icon has now been re-published on the Allen ISD portal for teachers only. Teacher access to Canva has remained available throughout the day; however, the IT Department needed to reconfigure the portal tile so that it is visible and accessible only to teachers at this time.

Teachers may need to log out of the Allen ISD portal and log back in for the Canva icon to appear again.

Student access to Canva remains temporarily disabled. Students are not able to access the Allen ISD Canva environment at this time, either through the Allen ISD portal or directly through the web.

We will provide further updates as more information becomes available.

Thank you for your patience and understanding.

Respectfully,
Allen ISD Information Technology Department
Posted Sep 16, 2026 - 13:18 CDT

Investigating

Hello Allen ISD Staff,

The IT Department and Canva (not Canvas) are aware of an issue affecting permissions and sharing within Canva. Canva has identified a permissions-related bug and is actively working to resolve it.

While Canva works on a fix, student access to Canva has been temporarily disabled across Allen ISD as a precautionary measure. This step is intended to help prevent misuse that has been observed in a limited number of instances over the past several days.

We will provide an update once Canva confirms the issue has been resolved and student access can be safely restored.

Thank you for your patience and understanding.

Respectfully,
Allen ISD Information Technology Department
Posted Sep 16, 2026 - 11:52 CDT
This incident affects: Academic Instructional Services (Other Teaching & Learning Platforms).