Google and Clever Access Issues

Incident Report for Allen ISD Information Technology

Resolved

Dear Allen ISD Staff,

The recent access issues with Google and Clever were resolved yesterday morning. Since then, the Allen ISD IT department has closely monitored performance, and user access has remained stable. School districts have been advised that full functionality was restored.

The Allen ISD IT department will continue to monitor system stability and provide updates if necessary.

Respectfully,
Allen ISD Information Technology Department
Posted Sep 19, 2025 - 09:42 CDT

Monitoring

Dear Allen ISD Staff,

Status Update: Google and Clever Status

Allen ISD IT is currently monitoring access failures in the Google and Clever infrastructure.
Users may encounter errors when attempting to log in or use these platforms.
We will provide an update when the issue has been resolved in Google and Clever’s infrastructure.

Thank you for your patience.

Respectfully,
Allen ISD Information Technology Department
Posted Sep 18, 2025 - 10:35 CDT
This incident affected: Collaboration and Sharing (Google G-Suite - Gmail) and Academic Instructional Services (Clever).