The issue affecting access to Skyward Finance and Skyward Student through the portal was successfully resolved last night.
We have monitored the fix and confirmed that services are working as expected. This incident is now considered closed.
Thank you for your patience as we worked to restore access.
— Allen ISD Information Technology Department
Posted Aug 04, 2025 - 09:01 CDT
Monitoring
Dear Allen Staff,
The issue affecting access to Skyward Finance and Skyward Student through the portal has been identified, and a fix has been successfully applied.
All staff access has now been restored.
Thank you for your patience as we worked to resolve the issue.
— Allen ISD Information Technology Department
Posted Aug 03, 2025 - 20:56 CDT
Investigating
Dear Alllen Staff,
We are currently experiencing an authentication error that is affecting staff access to Skyward Finance and Skyward Student through the portal. The Information Technology department is actively investigating the issue and is working with our service providers to resolve it as quickly as possible.
Please note: access to Skyward Family remains available, and families can still complete Beginning-of-Year forms without interruption.
Thank you for your patience and understanding.
– Allen ISD Information Technology Department
Posted Aug 03, 2025 - 20:23 CDT
This incident affected: Skyward Applications (Finance - HR Systems, Student Information Systems).