Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 10, 2026 - 22:00 CDT
Scheduled
Dear Allen ISD Staff,
Skyward’s hosting provider, ISCorp, notified school districts today of scheduled infrastructure maintenance taking place this evening. The maintenance is intended to implement additional resiliency and platform stability improvements.
Maintenance Window Specifics:
Monday, August 10, 2026, at 10:00 PM through Tuesday, August 11, 2026, at 1:00 AM CDT.
During this overnight maintenance window, the Allen ISD Skyward environment may experience brief or intermittent service disruptions. Skyward has indicated that only a limited number of districts are expected to be affected, and most customers should experience no disruption.
The Allen ISD IT Department will monitor the Skyward environment during the maintenance window.
No action is required from users at this time. If Allen ISD services are impacted, additional updates will be provided as appropriate.
Respectfully,
Allen ISD Information Technology Department
Posted Aug 10, 2026 - 18:41 CDT
This scheduled maintenance affected: Skyward Applications (Family Access, Finance - HR Systems, Student Information Systems).