Clever Access
Incident Report for Allen ISD Information Technology
Resolved
Clever is reporting this incident as resolved
Posted Mar 05, 2024 - 12:42 CST
Identified
Clever has identified an issue with Google that may impact some users' ability to log into applications within Clever. We are monitoring the issue and will provide status updates as they become available from Clever.
Posted Mar 05, 2024 - 10:41 CST
This incident affected: Academic Instructional Services (Clever).