Professional Learning and Data Dashboard Access Issues

Incident Report for Allen ISD Information Technology

Resolved

This incident has been resolved.
Posted Sep 18, 2025 - 14:20 CDT

Update

The Data Dashboard and Professional Learning platform are back online and fully operational. We are currently working on restoring professional learning records completed after noon on Wednesday 9/17 and will update them as quickly as possible. If your sessions are still not visible by next week, please submit a help ticket so we can assist you.
Posted Sep 18, 2025 - 14:19 CDT

Investigating

We are currently experiencing connectivity issues affecting the Professional Learning site and the Data Dashboard.
Our team is actively investigating and working to resolve the problem. We will provide an update as soon as the issue has been resolved.

Thank you for your patience.

Respectfully,
Allen ISD Information Technology Department
Posted Sep 18, 2025 - 12:37 CDT
This incident affected: Data Applications (Allen ISD Data Dashboard) and Academic Instructional Services (Other Teaching & Learning Platforms).