PowerSchool Perform - Login Issues
Incident Report for Allen ISD Information Technology
Resolved
This incident has been resolved.
Posted Mar 20, 2024 - 15:55 CDT
Investigating
We are currently investigating this issue.
Posted Mar 20, 2024 - 09:16 CDT
This incident affected: Academic Instructional Services (Other Teaching & Learning Platforms).