Update Skyward Mobile App & Use Web Browser for Family Access
Incident Report for Allen ISD Information Technology
Resolved
Allen ISD Staff,

The Skyward mobile application has been updated by the vendor and is now available for family access again. Please make sure you update the Skyward mobile app to the latest version before log in into Skyward Family Access. The update is also necessary to successfully log in into Skyward Finance and Student through the phone app.

See instructions below to complete the phone app update:

https://helpdesk.allenisd.org/kb/article/83-skyward-mobile-app-update-staff-account/

Respectfully,

Allen ISD Information Technology Department
Posted Oct 17, 2023 - 11:30 CDT
Monitoring
Dear Allen ISD Staff,

On Friday October 13, 2023, Skyward released an updated mobile app version (2.1.01) for access through iOS and Android devices. District staff who utilize the Skyward mobile application are advised to update the application and reconnect the AISD staff account to ensure functionality. Copy and paste the following link on your browser to access instructions if needed:

https://helpdesk.allenisd.org/kb/article/83-skyward-mobile-app-update-staff-account/

The Skyward Family Access phone application is producing an error when attempting to authenticate. The Allen ISD IT team has notified the vendor and asked for a timeline related to the bug fix. Please guide parents to utilize the web version to access Skyward Family Access linked on the allenisd.org website in the meantime.

The technical issue described above does not affect access to any of the Skyward environments (Student, Finance and Family) through the web browser. It is limited to the mobile application.
Posted Oct 16, 2023 - 15:53 CDT
This incident affected: Skyward Applications (Family Access, Finance - HR Systems, Student Information Systems).