Microsoft Products Authentication
Incident Report for Allen ISD Information Technology
Resolved
The Microsoft authentication issue that affected a small sub-set of users was fixed earlier today.
Thank you for your understanding and continued support.

Allen ISD Information Technology Department
Posted Mar 27, 2023 - 10:43 CDT
Identified
Some users may experience issues authenticating into Microsoft products.
The issue has been identified and the IT team is working with service providers to apply a fix as soon as possible.
Thank you for your understanding.
Posted Mar 24, 2023 - 09:01 CDT
This incident affected: Collaboration and Sharing (Office 365 - Cloud Applications, Office 365 - Exchange Email Services, Office 365 - Sharepoint Services).