PowerSchool Perform Direct Reports
Incident Report for Allen ISD Information Technology
Resolved
This incident has been resolved.
Posted Apr 11, 2024 - 09:43 CDT
Monitoring
The Information Technology Department has implemented a fix and is actively monitoring the results.
Posted Apr 05, 2024 - 09:00 CDT
Update
The Information Technology Department continues to work with the vendor to resolve the PowerSchool Perform issue as soon as possible. This is a priority, and we are currently waiting on a final step from the vendor for final resolution
Posted Apr 05, 2024 - 07:44 CDT
Identified
We are aware that users may no longer have supervisors or direct reports assigned in PowerSchool Perform. The problem has been identified and a fix is being implemented.
Posted Apr 03, 2024 - 14:21 CDT
This incident affected: Business Operations Services (Powerschool Perform).