Microsoft 365 services are degraded
Incident Report for Allen ISD Information Technology
Resolved
Microsoft has resolved the issue affecting Microsoft 365
Posted Sep 12, 2024 - 09:58 CDT
Update
We are continuing to montior for further issues.
Posted Sep 12, 2024 - 08:43 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 12, 2024 - 08:41 CDT
Investigating
Good Morning Allen ISD Staff,
We are currently experiencing degraded performance with Microsoft O365 services, as confirmed by Microsoft. They are actively addressing the issue and working to restore normal functionality as swiftly as possible. We appreciate your patience and understanding during this time.
For the latest updates, please visit: Microsoft Service Status.
Best regards,
Allen ISD IT Department
Posted Sep 12, 2024 - 08:25 CDT
This incident affected: Collaboration and Sharing (Office 365 - Cloud Applications).