HMH Ed is limited

Incident Report for Allen ISD Information Technology

Resolved

The issue has been resolved, and classes and content in HMH Ed are now loading as expected. Performance will continue to be closely monitored by HMH.
Posted Jan 09, 2026 - 15:19 CST

Investigating

There is a known issue currently under investigation where some classes and content are not displaying in Ed. HMH is investigating the issue, and we will provide updates as they become available.
Posted Jan 09, 2026 - 10:57 CST
This incident affected: Academic Instructional Services (Other Teaching & Learning Platforms).