Student to Student Email

Incident Report for Allen ISD Information Technology

Resolved

This incident has been resolved.
Posted Dec 12, 2025 - 15:41 CST

Monitoring

As part of the district's ongoing efforts to improve security, a new email protection tool for student accounts was deployed recently. Since the deployment date, the Information Technology Team and our vendors have been progressively updating and fine-tuning the protection policies and security settings to ensure strong safeguards while maintaining smooth communication.
During this adjustment period, we received reports that some student-to-student emails were not being delivered as expected. The Information Technology Team and our vendors investigated and identified that the issue was related to these updated protection policies.
The final issue was corrected on Tuesday, December 9 at 3:48 PM. Since that time, all student-to-student messages have been showing as successfully delivered in our system logs. Based on this data, we believe the issue has been fully resolved.
We will continue monitoring the system as the new protection tool settles in to ensure consistent and stable performance.
Thank you for your patience and support as we strengthen email security for our students.
Posted Dec 10, 2025 - 11:11 CST
This incident affected: Collaboration and Sharing (Google G-Suite - Gmail).