Canon Copier - Secure Print
Incident Report for Allen ISD Information Technology
Resolved
The secure print issue with Canon copiers has been resolved. Everything is now functioning normally. Thank you for your patience!
Posted Aug 30, 2024 - 15:25 CDT
Update
We are continuing to investigate this issue.
Posted Aug 30, 2024 - 15:20 CDT
Investigating
The Secure Print option on the Canon Copiers is down.

Our IT team is aware and actively working to resolve the problem as quickly as possible. We appreciate your patience and understanding during this time.

Respectfully,

Information Technology Department
Allen ISD
Posted Aug 30, 2024 - 14:22 CDT
This incident affected: Business Operations Services (Uniflow - Canon copier access).