Ongoing Cloud Provider Outage

Incident Report for Allen ISD Information Technology

Resolved

Dear Allen ISD Staff,

The recent cloud provider outage has been resolved. All affected services, including Canva, are now fully operational.

Thank you for your patience and understanding during this time. If you experience any further issues, please contact the Help Desk at helpdesk@allenisd.org

Regards,

Allen ISD IT Department
Posted Nov 18, 2025 - 13:28 CST

Monitoring

Dear Allen ISD Staff,

One of our cloud providers is currently experiencing a global outage, which may affect some of the applications and services used within the district, including Canva. Our team is aware of this issue and actively monitoring the situation. We will continue to provide updates as more information becomes available.

We appreciate your patience and understanding during this time.

Respectfully,

Allen ISD IT Department
Posted Nov 18, 2025 - 08:23 CST
This incident affected: Academic Instructional Services (Other Teaching & Learning Platforms, Professional Learning Platform).