Websites Unreachable

Incident Report for Allen ISD Information Technology

Resolved

This incident has been resolved.
Posted Jul 24, 2025 - 09:44 CDT

Investigating

Access to the Professional Learning/Compliance Platform and Data Dashboard is currently unavailable to all users.
The IT team is working on fixing the issue to restore full functionality as quickly as possible.
We apologize for the inconvenience and appreciate your patience during this time.
Posted Jul 24, 2025 - 09:13 CDT
This incident affected: Data Applications (Allen ISD Data Dashboard) and Academic Instructional Services (PowerSchool Professional Learning).