The temporary issue affecting password reset requests has been resolved. Users should now be able to successfully reset their passwords as expected.
Thank you for your patience and understanding while our team worked to resolve this issue. We apologize for any inconvenience this may have caused.
If you continue to experience any issues with password resets, please contact the Allen ISD Help Desk at 469-675-2000 for assistance.
Thank you,
Posted Jul 14, 2026 - 11:24 CDT
Identified
Dear Allen ISD Staff,
Allen ISD Technology Services is currently experiencing a temporary issue affecting password reset requests. Our team is aware of the issue and is actively working to resolve it.
At this time, we kindly ask that you please refrain from attempting to reset your password until further notice. Our team is working to restore the service as quickly as possible, and additional reset attempts may not be successful while the issue is ongoing.
We apologize for any inconvenience this may cause and appreciate your patience and understanding while we work to resolve the issue.
We will provide an update once password reset functionality has been restored.
Thank you for your cooperation.
Posted Jul 14, 2026 - 09:48 CDT
This incident affected: Business Operations Services (Single Sign-On Portal - (Emp/Student)).