Power Outage Affecting Network Equipment

Incident Report for Allen ISD Information Technology

Resolved

The power outage affecting some sites has been resolved, and network services are now fully operational.

Please reach out if you experience any further issues.
Posted Mar 05, 2025 - 08:09 CST

Investigating

Hello,

It appears that some or all of the following sites are currently without electric power, and network equipment is running on battery backup at this time:

Admin
PLAS
Bolin
Boyd
Chandler
Dillard
Reed
Service Center

We are monitoring the situation and will provide updates as needed. Please let us know if you experience any additional issues.
Posted Mar 04, 2025 - 08:53 CST
This incident affected: Network Infrastructure Services (Campus Network Services, Data Center Services, Internet Access).