NWEA MAP Growth Testing

Incident Report for Allen ISD Information Technology

Resolved

NWEA MAP Growth Testing has been resolved. Services are now fully operational and stable.

Thank you for your patience during the disruption. If you continue to experience any issues, please submit a Help Ticket.
Posted May 06, 2025 - 15:52 CDT

Monitoring

NWEA has reported that MAP Growth Testing services are back online and operating normally.

Our team is continuing to monitor performance on our end to ensure full functionality and a smooth experience for all users.

Thank you for your patience while the issue was being resolved. We will provide a final update once monitoring is complete.
Posted May 06, 2025 - 10:50 CDT

Investigating

NWEA has reported an incident affecting MAP Growth Testing. Users may experience intermittent issues with student testing, administrative interfaces, and reporting tools. NWEA is actively working to resolve the issue

For updates, please refer to NWEA's official status page at https://status.nwea.org/

We will continue to monitor the situation and provide updates as they become available.

Thank you for your patience and understanding.
Posted May 06, 2025 - 09:43 CDT
This incident affected: Academic Instructional Services (Other Teaching & Learning Platforms).