Laserfiche Forms – Service Degradation

Incident Report for Allen ISD Information Technology

Resolved

Allen ISD Staff,

Laserfiche services are operational at this time. The Information Technology Department is continuing to monitor the system following the outage and recovery.

Thank you for your patience and understanding.

Respectfully,

Allen ISD Information Technology Department
Posted Aug 05, 2026 - 12:52 CDT

Monitoring

Allen ISD Staff,

Laserfiche services are operational at this time. The Information Technology Department is continuing to monitor the system following the outage and recovery.

As a result of the recovery process, some documents added to Laserfiche repositories after approximately 9:30 a.m. yesterday may not be available.

Thank you for your patience and understanding.

Respectfully,

Allen ISD Information Technology Department
Posted Aug 05, 2026 - 08:29 CDT

Identified

Allen ISD Staff,

Laserfiche is currently unavailable but is in the process of being brought back online. The Information Technology Department is aware of the issue and actively working toward a resolution.

We will provide an update once service has been restored.

Respectfully,

Allen ISD Information Technology Department
Posted Aug 05, 2026 - 07:08 CDT

Investigating

Dear Allen ISD Staff,

We are currently experiencing intermittent issues with accessing and using Laserfiche Forms.

Users may encounter occasional errors, slow performance, or difficulty accessing forms. Our team is actively investigating the issue and working diligently to diagnose and resolve it as quickly as possible.

We appreciate your patience and understanding while we work to restore normal service. Updates will be posted here as more information becomes available.

Respectfully,

Allen ISD Information Technology Department
Posted Jul 30, 2026 - 19:10 CDT
This incident affected: Business Operations Services (Laserfiche Document Management).