Critical Palo Alto Firewall Maintenance
Incident Report for Allen ISD Information Technology
Resolved
We have completed the remediations at this time.

Thanks again for your patience!
Posted Apr 15, 2024 - 12:43 CDT
Identified
Palo Alto Networks has discovered and publicized a critical vulnerability in their firewall systems utilized by organizations worldwide.

Allen ISD uses Palo Alto firewall appliances that are covered under that umbrella at all 3 major internet ingress/egress points of the district network.

What this is:

• A software vulnerability that would potentially allow unauthorized access to our internal network infrastructure.
• Due to the nature and severity of the vulnerability, we are required to take action in real time to reduce or eliminate chances of unauthorized access to systems and services.

What this is not:

• A data breach or exposure on any scale
• A ransomware attack

Palo has released guidance on how to remediate this vulnerability, but will require rolling outages of certain district services for up to 2 hours.

During that time period you may have issues accessing Skyward and ERMA using the vanity URLS (erma.allenisd.org and skyward.allenisd.org).

Use the URLs below to access Skyward directly during that time period:

ERMA:

https://skyward.iscorp.com/scripts/wsisa.dll/WService=wsfinallenisdtx/seplog01.w

Student:

https://skyward.iscorp.com/scripts/wsisa.dll/WService=wseduallenisdtx/seplog01.w

There may be intermittent outages for the following services throughout this timeframe:

EduPhoria
Data Dashboard (AIMS)
LaserFiche
Video Insight
PowerSchool Perform

We will keep you posted on any additional expected outages and remediation throughout the day.

Thank you for your patience!
Posted Apr 15, 2024 - 08:41 CDT
This incident affected: Network Infrastructure Services (Campus Network Services, Data Center Services, Fiber Network Connectivity (WAN), Firewall Services, Internet Access, IP Services, Video Insights Systems), Data Applications (Allen ISD Data Dashboard), Skyward Applications (Finance - HR Systems, Student Information Systems), Telecommunications Systems (Fax Services), Academic Instructional Services (Eduphoria, Other Teaching & Learning Platforms), and Business Operations Services (Laserfiche Document Management, Powerschool Perform).