Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 24, 2026 - 10:00 CDT
Scheduled
Skyward Student Access and Family Access will be unavailable due to scheduled software maintenance on Wednesday, June 24, 2026, from 10:00 AM until approximately 6:00 PM.
During this maintenance window, staff, students, and parents/guardians will be unable to access student data through Skyward. In addition, guardians using the New Student Online Enrollment system will not be able to enroll students during this time.
Skyward Student Access and Family Access are expected to be available again at approximately 6:00 PM once maintenance has been completed.
Thank you for your patience and understanding during this maintenance period.
Posted Jun 23, 2026 - 13:12 CDT
This scheduled maintenance affects: Skyward Applications (Family Access, Student Information Systems).