A fix to restore the normal access in GoGuardian for campus administrators was applied on Wednesday, and the IT Department has been monitoring and testing the results since then. The issue has been resolved at this time. A very limited number of users may experience access issues due to the changes implemented by GoGuardian. This should be extremely limited and for special cases only. If you encounter difficulties, please enter a Help Desk ticket so our support team can assist you promptly.
Respectfully,
Allen ISD IT Department
Posted Aug 22, 2025 - 14:35 CDT
Update
Dear Allen ISD Staff,
The Allen ISD IT Department will be applying a fix that will sync overnight. We will monitor the results first thing tomorrow morning before school starts to ensure seamless access is fully restored for administrators.
We want to reiterate that this access issue only affects administrators and does not impact classroom teachers, and that filtering for students is still occurring as intended.
In the meantime, administrators can still log in into their Go Guardian dashboard by following the next steps:
1 - If you see the error message “Login failed. Please try again”, click on “Go to Login.” 2 - Then select “Access with Google” to complete the login.
Respectfully,
Allen ISD Information Technology Department
Posted Aug 19, 2025 - 15:29 CDT
Identified
Dear Allen ISD Staff,
It has come to our attention that a recent, unannounced configuration change by GoGuardian has temporarily impacted administrative staff access to the platform. The district's IT department has been in direct contact with GoGuardian representatives to identify the root cause of the issue and confirm a solution. We are actively implementing the fix to restore access for affected users as quickly as possible.
Important notes:
1- Student monitoring and internet filtering remain fully operational.
2- Classroom teachers are not affected by this access issue - only administrative staff as applicable
3- The issue is limited primarily to administrator logins.
We will provide an additional update once the fix has been fully applied and access has been restored for administrators. Thank you for your patience and understanding as we work to resolve this matter.