HMH/myHRW/ThinkCentral Outage
Incident Report for Allen ISD Information Technology
Resolved
This incident has been resolved.
Posted Feb 09, 2024 - 14:52 CST
Identified
We have identified an issue preventing logins to HMH Ed/myHRW/ThinkCentral and are implementing a fix at this time.
Posted Feb 09, 2024 - 09:44 CST
This incident affected: Academic Instructional Services (Other Teaching & Learning Platforms).