Test Email from Allen ISD IT

Incident Report for Allen ISD Information Technology

Resolved

This incident has been resolved.
Posted Jun 10, 2025 - 12:32 CDT

Identified

Test Email from Allen ISD IT
Posted Jun 10, 2025 - 12:15 CDT
This incident affected: Academic Instructional Services (Other Teaching & Learning Platforms).