SSL/TLS Security Issue
Incident Report for Allen ISD Information Technology
Resolved
This incident has been resolved.
Posted Oct 31, 2023 - 15:36 CDT
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 25, 2023 - 12:52 CDT
This incident affected: Data Applications (Allen ISD Data Dashboard), Academic Instructional Services (Eduphoria), and Business Operations Services (Laserfiche Document Management, WinOcular Systems).