Laserfiche Outage – Service Currently Unavailable

Incident Report for Allen ISD Information Technology

Resolved

Dear Allen ISD Staff,

Laserfiche services have been restored and are now back online.

The issue affecting the service was identified and resolved. The Information Technology team will continue to monitor the system to ensure stability and access.

Respectfully,

Allen ISD Information Technology Department
Posted May 01, 2026 - 09:24 CDT

Investigating

Allen ISD Staff,

Laserfiche is currently experiencing an outage and is not available at this time.

The Information Technology team is actively working toward a resolution and will keep staff informed as progress is made.

Respectfully,

Allen ISD Information Technology Department
Posted May 01, 2026 - 08:24 CDT
This incident affected: Business Operations Services (Laserfiche Document Management).