NWEA Outage
Incident Report for Allen ISD Information Technology
Resolved
NWEA has resolved the issue at this time. Thank you for your patience
Posted Sep 04, 2024 - 15:33 CDT
Identified
NWEA engineers are currently investigating an issue where some partners are unable to log in to access the MAP Suite of products. This includes MAP Growth, MAP Reading Fluency, MAP Accelerator, and Acacia. Some partners can log in and access the start page but are noticing a slower load time than usual.

We recommend continuing testing if you can log in successfully.

You may monitor this from going to NWEA site: https://status.nwea.org/incidents/nd39srtxy5lx
Posted Sep 04, 2024 - 08:30 CDT
This incident affected: Academic Instructional Services (Other Teaching & Learning Platforms).