Phone Issue - Auto Attendant Outage
Incident Report for Allen ISD Information Technology
Resolved
This incident has been resolved.
Posted Sep 14, 2020 - 10:08 CDT
Investigating
This is to inform you that we are currently experience an issue with the Auto Attendant feature of our phone system. This will affect 972-236-0600 and 469-319-6390.

We are working with our service provider and vendor to resolve the issue.
Posted Aug 07, 2020 - 13:36 CDT
This incident affected: Telecommunications Systems (Campus Phone Systems).