Google Drive Partial Outage
Incident Report for Allen ISD Information Technology
Resolved
Google reports the issue has been resolved.
Posted Sep 15, 2020 - 12:08 CDT
Investigating
Google has reported that they are investigating an issue with Google Drive. Our staff and students may experience issues trying to access their Google Drive files.
Posted Sep 15, 2020 - 09:45 CDT
This incident affected: Collaboration and Sharing (Google G-Suite - Drive).