Pearson Realize is experience performance issues.
Incident Report for Allen ISD Information Technology
Resolved
This incident has been resolved.
Posted Jun 08, 2020 - 08:22 CDT
Investigating
Due to high volume, Pearson Realize is experience performance and login problems. Pearson is working to resolve these issues, and we will keep this page updated as we hear from them.
Posted Mar 31, 2020 - 14:58 CDT
This incident affected: Academic Instructional Services (Other Teaching & Learning Platforms).